Mileage reading incorrectly

I had this issue before, where my rides were reporting 160+ miles, and avg speeds around 60mph. I found it was the wheel size setting. Interestingly I had mine set to the correct size. I tried the one for the Bkool Pro (my trainer) and it was still off, but managed to find a setting that worked. 

After riding outside for summer I came back recently and am experiencing the opposite issue. I have tried multiple diameters from the correct ones and vastly incorrect and it comes up with somewhat random readings. Max speed of 47mph and avg of 2.1mph and will show I did 1 mile in a workout like The Shovel. I've turned the trainer on/off, checked tire pressure, I don't know what else I can try. The cadence and power readings seem to be fine, but the speed/distance is off on every ride. 

0

Comments

1 comment
  • Hi Adam,

    All smart trainers report speed, and therefore distance, a bit differently.  These readings can change with various firmware and app updates as well.  So the bad news is that I don't have a quick answer for the issue that you are seeing.  The good news is that we are working on a new algorithm (in an upcoming release) that will balance out these differences and hopefully give everyone more consistent speed and distance readings.  

Please sign in to leave a comment.

Didn't find what you were looking for?

New post